Die Funktion SUMMEWENN in Excel (Teil 1)

Summewennfunktion2

In dem vorangegangenen Beitrag zeigte ich beispielhaft, welche Schreibweisen möglich sind, um ein gewünschtes Ergebnis zu erzielen.

Heute geht es um die Funktion SUMMEWENN. Diese Funktion ermöglicht dir eine Summenbildung unter einer Bedingung. Dazu habe ich wieder ein paar Beispiele vorbereitet, die dir die Funktionsweise deutlich machen sollen.

SUMMEWENN addiert die Werte, die mit den Suchkriterien übereinstimmen.

Die Syntax lautet:

SUMMEWENN(Bereich;Kriterien;Summe_Bereich)

Dabei sind:

Bereich: ist der Zellbereich, den Sie nach Kriterien auswerten möchten. Zulässige Zellen in jedem Bereich sind Zahlen oder Namen von, Arrays von oder Bezüge zu Zellen, die Zahlen enthalten. Leere Zellen und Textwerte werden ignoriert.

Kriterien: gibt die Kriterien in Form einer Zahl, eines Ausdrucks oder einer Zeichenfolge an. Diese Kriterien bestimmen, welche Zellen addiert werden. Zum Beispiel kann das Argument Kriterien als 32, “32”, “>32” oder “Äpfel” formuliert werden.

Summe_Bereich: sind die tatsächlich zu addierenden Zellen, wenn die Inhalte ihrer entsprechenden Zellen in Bereich mit den Suchkriterien übereinstimmen.

Welcher Art können die Kriterien sein?

Es können Wörter als Kriterium bestimmt werden, die mit einem Buchstaben oder einer Buchstabenfolge beginnen, enden, diese enthalten oder diesen entsprechen.

Es können Buchstaben oder Buchstabenfolgen bestimmt werden, die nicht enthalten sein dürfen.

Es können Zahlenwerte bestimmt werden, die kleiner, gleich oder größer als ein Vorgabewert sind.

Es können Zahlenwerte bestimmt werden, die mit einer Zahl beginnen, enden, diese enthalten oder diesen entsprechen.

Es können Zahlenwerte bestimmt werden, die zwischen einem Maximum und einem Minimum liegen.

Es können Zahlen bestimmt werden, die nicht enthalten sein dürfen.

Beispiel 1

Erinnerst du dich an Beispiel 11 aus meinem Beitrag zur Funktion SUMME? Mit SUMMEWENN löse ich die Aufgabe so:

summewennfunktion1

=SUMMEWENN(B40:B46;”>90″;B40:B46)  =309

Beachte, dass du in dieser Formel die Bedingung in Anführungszeichen schreiben musst. Sonst bekommst du eine Fehlermeldung.

Du kannst hier die Angabe von “Summe_Bereich” auch weglassen, denn der Bereich, für den die Bedingung gesetzt wird ist mit dem Bereich, der summiert werden soll, identisch.

=SUMMEWENN(B40:B46;”>90″)  =309

Beispiel 2

Die folgende kleine Tabelle zeigt verschiedene Orte sowie die dort verkauften Stückzahlen. Es sollen die Verkaufsmengen des Ortes Flensburg summiert werden.

Summewennfunktion2

Der Bereich für das Suchkriterium (Ort) ist also ein anderer als der Bereich für die Summierung (Mengen).

=SUMMEWENN(B64:B75;”Flensburg”;C64:C75)  =9.280

Es wird zunächst die Spalte Ort nach “Flensburg” abgesucht. Trifft das Suchkriterium zu, werden die zugehörigen Mengen addiert.

Beispiel 3

Für das Suchkriterium richte ich mir über Daten / Datenüberprüfung ein DropDown-Feld ein. Der Bereich B64:B75 erhält dazu den Namen “Ort”, der Bereich C64:C75 den Namen “Mengen”.

summewennfunktion3
4550ef741a0c440da5f9fd8995c05c18
In B94 schreibe ich die Formel:

=SUMMEWENN(Ort;$B$92;Mengen)

2 Gedanken zu „Die Funktion SUMMEWENN in Excel (Teil 1)“

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert

WordPress Cookie Plugin von Real Cookie Banner