Zählen mit ANZAHLWENN?

anzahlwenn3 1

(Neubearbeitung 06.04.2021)

Als aufmerksamer Leser hast Du sicherlich sofort festgestellt, dass es diese Funktion bei Excel gar nicht gibt. Bekannt sind die Funktionen ANZAHL, ANZAHL2, ZÄHLENWENN und ZÄHLENWENNS. ANZAHLWENN gibt es eben nicht.

eaf5a1612831420b9ad998b6ff4f5d95

Was soll ein solcher Beitrag, wenn es eine Funktion ANZAHLWENN gar nicht gibt?

Ich fand es interessant, herauszufinden, ob eine Kombination von ANZAHL und WENN ein Ergebnis, ein richtiges Ergebnis liefert.

Dazu habe ich 10 Zahlenwerte untereinander geschrieben und will nun wissen, wie viele Werte enthalten sind, die kleiner als 32 sind.

Anzahlwenn1

Mit der Formel  =ZÄHLENWENN(B3:B12;”<32″) erhalte ich das Ergebnis 5. Das ist wohl richtig.

Nun schreibe ich  =ANZAHL(WENN(B3:B12<32;1)) und erhalte als Ergebnis 0. Das ist wohl nicht richtig.

Schließe ich die Formel jedoch mit Strg+Shift+Enter ab, als Matrixformel, erhalte ich als Ergebnis 5. Und das ist richtig.

Die Formel sieht so aus:  {=ANZAHL(WENN(B3:B12<32;1))}

Warum ist die Formel als Matrixformel abzuschließen? Excel soll nicht nur prüfen, ob der Wert aus B3 kleiner als 32 ist, sondern alle Werte aus B3:B12 prüfen.

Du siehst, ANZAHLWENN gibt es nicht, aber mit ANZAHL(WENN( … )) geht es auch.

Mit ZÄHLENWENNS kannst Du arbeiten, wenn es eine weitere Bedingung gibt, z.B. “>27”.

=ZÄHLENWENNS(B3:B12;”<32″;B3:B12;”>27″)

Ergebnis ist 4. Dahinter verberge sich die Werte 29, 8, 31 und 31.

Allerdings erhältst Du mit dieser Formel auch das Ergebnis 4:

{=ANZAHL(WENN(B3:B12<32;WENN(B3:B12>27;B3:B12;””)))}

Schließe auch diese Formel mit Strg+Shift+Enter als Matrixfunktion ab.

Du arbeitest so mit einer verschachtelten WENN-Funktion. Zuerst wird mit WENN nach den Werten <32 gesucht, dann mit der zweiten WENN-Funktion nach den Werten >27. Trifft beides nicht zu, soll “” (nichts) ausgegeben werden.

Bleibt noch die Suche nach einer Formel, die sowohl ANZAHL als auch WENNS verwendet. Dazu zeige ich zunächst eine Möglichkeit mit einer Hilfsspalte.

Anzahlwenn2

Mit der Formel

=WENNS(B3>=32;””;B3>27;1;WAHR;””)

in Zelle C3 wird angewiesen, zu prüfen, ob B3 einen Werte >= 32 enthält. Wenn ja, soll “” ausgegeben werden. Im zweiten Schritt wird geprüft, ob B3 einen Wert >27 enthält. Wenn ja, soll 1 ausgegeben werden. Wenn keine der gesetzten Bedingungen zutrifft, wird als letztes Argument der Wert WAHR gesetzt und damit “” ausgegeben. Die Summe der in Spalte C ausgegebenen Werte beträgt 4.

Verpacke nun das Ganze in eine Formel mit den Funktionen ANZAHL und WENNS.

{=ANZAHL(WENNS(B3:B12>=32;””;B3:B12>27;1;WAHR;””))}

Wähle dazu jeweils den Bereich B3:B12 aus, wähle ansonsten die vorherige Formel und setze ANZAHL davor. Schließe wieder mit Strg+Shift+Enter ab.

Quelle Beitragsbild:

https://www.bing.com/images/search?q=z%c3%a4hlen&qpvt=z%c3%a4hlen&form=IGRE&first=1&tsc=ImageHoverTitle

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert

WordPress Cookie Plugin von Real Cookie Banner