Formelanalyse – Formeln in mehrere Zellen aufteilen

formelanalyse35 1

Eine letzte Möglichkeit, eine Formel zu verstehen, ist diese aufzuteilen.

Was heißt aufteilen?

Eine Formel aufzuteilen bedeutet, einzelne Elemente in neue Zellen zu kopieren, dort Teilrechnungen vorzunehmen und somit einen besseren Überblick zu erhalten.

Wie es geht, zeigt der Beitrag.

bb47795bacad49c997e13edb907a8b2e

1. Das Beispiel

Bilde Dir einen Wertebereich mit 30 Werte, z.B. mit Hilfe der Funktion ZUFALLSBEREICH().

Formelanalyse32

Für die Formel, die in Zelle C15 eingetragen werden soll, benötigst Du die Angaben einer Zeile und einer Spalte. Dazu sind F3:F4 vorgesehen.

In C15 trage diese Formel ein:

=WENN(ANZAHL(B3:D12)>=30;INDEX(B3:D12;F3;F4);MITTELWERT(B3:D12))

Mache Dir zunächst klar, was gemacht werden soll. Mit der WENN-Abfrage stellst Du die Bedingung, dass der Wertebereich B3:D12 eine Anzahl an Werten von mindestens 30 enthalten soll.

Wenn dem so ist, soll mit der INDEX-Funktion gerechnet werden. Wenn dem nicht so ist, soll ein MITTELWERT berechnet werden.

2. Formelzerlegung

Nun zerlegst Du die Formel in ihre Bestandteile. Beginne mit der ganzen Formel.

Formelanalyse33

Zerlege dann die Formel in ihre Bestandteile.

Berechne =ANZAHL(B3:D12)>=30. Das Ergebnis ist „WAHR“. Das heißt, der ausgewählte Bereich hat mindestens 30 Werte.

Berechne dann INDEX(B3:D12;F3;F4). Das Ergebnis ist 42, wie auch das Ergebnis der gesamten Formel. Das heißt, dieser Teil der Formel berechnet das eigentliche Gesamtergebnis.

Berechne zuletzt =MITTELWERT(B3:D12). Das Ergebnis ist 61,83333. Dieses Ergebnis ist aber nur relevant, wenn die Prüfung in der WENN-Abfrage ein „FALSCH“ ergibt.

Nehme zum Test einen Wert aus der Wertetabelle heraus.

Formelanalyse34

Die Prüfung der ANZAHL ergibt nun einen Wert unter 30. Es wird deshalb nicht der INDEX, sondern der MITTELWERT gerechnet. Der Mittelwert ist hier natürlich etwas geringer als bei voller Werteanzahl.

Das war es schon mit der Formelzerlegung. Sicher, die gewählte Formel war relativ einfach und insofern auch ohne eine Zerlegung zu verstehen.

Bei komplexen Formeln, kann eine solche Zerlegung jedoch sehr hilfreich sein. Probiere es gern aus.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert

WordPress Cookie Plugin von Real Cookie Banner