Bedingte Formatierung mit der VERGLEICH-Funktion

bedformatstadt5

Angenommen, Du hast eine Städteliste, hier im Beispiel sind 33 Städte aus Mecklenburg-Vorpommern dargestellt. Im Land gibt es 84 Städte.

eefb39fa140b43f9ae666a2e0cba6239

bedformatstadt1

Vergib über Formel / Namen definieren für den Bereich A3:A35 den Namen „Städte“.

Weiterhin hast Du eine kleine Liste mit Filialen eines Handelsunternehmens.

bedformatstadt2

Vergib über Formeln / Namen definieren für den Bereich C3:C10 z.B. den Namen „Filialen“.

Die Aufgabe besteht nun darin, mittels bedingter Formatierung zu prüfen, ob die Städteliste die Orte der Filialen enthält.

Hierzu kannst Du die Funktion VERGLEICH nutzen.

VERGLEICH liefert eine Zahl, wenn eine Stadt auch in der Liste „Filialen“ vorhanden ist.

Beispiel:

Schreibe folgende Formel:

=VERGLEICH(A12;Filialen;0)

In A12 steht die Stadt  „Goldberg“. Diese Stadt ist in der Liste „Filialen“ enthalten.

VERGLEICH gibt deshalb den Wert „2“ zurück, die Position der Stadt in der Städteliste.

Schreibe noch eine Formel:

=VERGLEICH(A13;Filialen;0)

In A13 steht die Stadt „Grabow“. Diese Stadt wird nicht unter den Filialen gefunden. Excel gibt deshalb den Fehlerwert „#NV“ zurück.

Verwende nun die Formel in der bedingten Formatierung.

Markiere A3:A35. Gehe im Menü Start auf „Bedingte Formatierung“ und wähle „Neue Regel“.

Wähle dort „Formel zur Ermittlung der zu formatierenden Zellen verwenden“.

Schreibe in die Regelbeschreibung nun die Formel:

=VERGLEICH(A3;Filialen;0)

Gehe auf Formatieren und treffe Deine Auswahl. Hier im Beispiel wurde eine gelbe Hintergrundfarbe ausgesucht.

bedformatstadt3

Gebe „OK“. Die Städteliste ist nun bedingt formatiert.

bedformatstadt4

Nun könntest Du noch sicherstellen, dass das VERGLEICH-Ergebnis tatsächlich eine Zahl ist.

Schalte dazu einfach die Funktion ISTZAHL vor die VERGLEICH-Funktion.

bedformatstadt5

Auf die Städteliste hat dies jedoch keine sichtbaren Auswirkungen. Allein für die bedingte Formatierung genügt die Formel

=VERGLEICH(A3;Filialen;0)

Willst Du jedoch außerhalb der bedingten Formatierung weitere Aktionen vornehmen, kann das Vorsetzen von ISTZAHL sinnvoll sein.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert

WordPress Cookie Plugin von Real Cookie Banner