Das Steuerelement ToggleButton

Toggle5

Der ToggleButton oder auf Deutsch die Umschaltfläche erfüllt ähnliche Aufgaben wie eine CheckBox (Kontrollkästchen) oder ein OptionButton (Optionsfeld).

Er dient der Eingabe und Anzeige von Wahrheitswerten (WAHR oder FALSCH).

In diesem Beitrag will ich dir zwei Verwendungsmöglichkeiten des ToggleButton zeigen.

1. Einen ToggleButton ins Arbeitsblatt einfügen

Rufe dazu die Entwicklertools in der Menüleiste und dann Einfügen auf.

Wähle die Umschaltfläche und klicke auf eine Zelle im Arbeitsblatt, über der das ToggleButton liegen soll.

Bleibe im Entwurfsmodus und gehe auf Eigenschaften. Trage dort zumindest bei Height und Weight Werte ein, damit der Button brauchbar aussieht.

Trage dann noch unter LinkedCell eine Zelladresse ein, die WAHR oder FALSCH ausweist, je nach Stellung des ToggleButtons.

Verlasse dann den Entwurfsmodus.

2. Netto + Mehrwertsteuer = Brutto

Im Beispiel geht es darum, einen Bruttowert zu errechnen. Dazu kannst Du auf einen Nettowert die Mehrwertsteuer aufschlagen oder auch nicht.

Zur Auswahl der Option kannst Du den ToggleButton verwenden.

In der ersten Abbildung steht in D7 (die ausgewählte LinkedCell) das Wort „WAHR“.

Die Formel in G9

=WENN(D7=WAHR;$F9*$G$8;”ohne”)

bezieht sich darauf. Steht in D7 demnach ein WAHR, wird der Nettobetrag in F9 mit dem Mehrwertsteuersatz in G8 multipliziert. In H9 schließlich wird die Summe aus F9 und G9 berechnet.

Toggle2

Steht in D7 FALSCH, wird keine Mehrwertsteuer berechnet und der Bruttowert ist gleich dem Nettowert.

Toggle1 1

3. Umschalten zwischen Anzeige als EUR oder TEUR

Im zweiten Beispiel kannst Du das Zahlenformat einer Zahlenreihe mit dem ToggleButton ändern.

Toggle3

Dazu habe ich in D18 die Formel

=WAHL($H$20;$B18/1;$B18/1000)

eingetragen und bis D32 heruntergezogen, das Bild zeigt nur die Zellen bis Zeile 21.

Die Abbildung zeigt den Zustand „Anzeige in EUR“ und es wird der Wert aus B18 ausgewiesen. In der LinkedCell H18 steht der Wahrheitswert WAHR.

Klicke nun den ToggleButton2 an und es wird auf die „Anzeige In TEUR“ umgeschaltet. In H18 steht nun FALSCH und in D18:D32 wird der Wert aus B18:B32 durch 1000 dividiert.

Toggle4

Über diesen Link kannst du dir die Beispieldatei herunterladen.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert

WordPress Cookie Plugin von Real Cookie Banner