Bedingte Formatierung bei Auswahl der Fälle

BedingtFaelle1

Die bedingte Formatierung bietet eine Vielzahl an Möglichkeiten, bestimmte Zellen hervorzuheben.

Das kann auf den Werten einzelner Zellen basieren, aber auch an mehrere Bedingungen geknüpft sein.

In diesem Beitrag wird nun gezeigt, wie eine bestimmte bedingte Formatierung gewählt werden kann.

Es geht darum, die Werte, die größer als der Mittelwert sind oder die Werte, die kleiner als der Mittelwert sind oder die bedingte Formatierung auszuschalten.

1. Die Wertetabelle

Mit Hilfe der Funktion ZUFALLSBEREICH() werden 12 Werte in einer Liste dargestellt.

BedingtFaelle1

In Zelle D17 berechnest du mit der Funktion MITTELWERT den Mittelwert der 12 Werte.

2. Das Drehfeld zur Auswahl

Wähle im Menü Entwicklertools / Steuerelemente unter Einfügen das Drehfeld aus und positioniere es in deinem Arbeitsblatt z. B. über der Zelle D4.

Klicke mit der rechten Maustaste auf das Drehfeld und wähle Steuerelement formatieren.

Trage die Werte wie in der Abbildung ein und bestätige mit OK.

BedingtFaelle2

Die verknüpfte Zelle soll E4 sein.

In F4 könntest du jetzt noch diese Formel einbauen:

=WENN(E4=1;”Formatierte Werte größer Mittelwert”;WENN(E4=2;”Formatierte Werte kleiner Mittelwert”;WENN(E4=3;”Keine bedingte Formatierung”)))

Damit erkennst du, welche bedingte Formatierung ausgewählt ist.

BedingtFaelle3

3. Bedingte Formatierung der Werte, die größer als der Mittelwert sind

Markiere den Bereich B4:B15, gehe im Menü Start / Formatvorlagen in die Bedingte Formatierung.

Wähle dort „Neue Regel“ und „Formel zur Ermittlung …“.

Trage diese Formel in die Regelbeschreibung ein:

=WENN(UND($E$4=1;B4>$D$17);1)

Es müssen zwei Bedingungen erfüllt sein, deshalb die Funktion UND():

In Zelle E4 muss eine „1“ stehen, in F4 steht passend dazu „Formatierte Werte größer Mittelwert“.

Der Wert in den Zellen B4:B15 muss jeweils größer als der Wert in D17 sein.

Wenn das gegeben ist, sollen die zutreffenden Zellen blau formatiert werden.

BedingtFaelle4

4. Bedingte Formatierung der Werte, die kleiner als der Mittelwert sind

Markiere den Bereich B4:B15, gehe im Menü Start / Formatvorlagen in die Bedingte Formatierung.

Wähle dort „Neue Regel“ und „Formel zur Ermittlung …“.

Trage diese Formel in die Regelbeschreibung ein:

=WENN(UND($E$4=2;B4<$D$17);1)

Es müssen zwei Bedingungen erfüllt sein, deshalb die Funktion UND():

In Zelle E4 muss eine „2“ stehen, in F4 steht passend dazu „Formatierte Werte kleiner Mittelwert“.

Der Wert in den Zellen B4:B15 muss jeweils kleiner als der Wert in D17 sein.

Wenn das gegeben ist, sollen die zutreffenden Zellen grün formatiert werden.

BedingtFaelle5

5. Bedingte Formatierung ausschalten

Markiere den Bereich B4:B15, gehe im Menü Start / Formatvorlagen in die Bedingte Formatierung.

Wähle dort „Neue Regel“ und „Formel zur Ermittlung …“.

Trage diese Formel in die Regelbeschreibung ein:

=WENN($E$4=3;1)

Es muss hier nur eine Bedingung erfüllt sein, in E4 muss eine 3 und in F4 „Keine bedingte Formatierung“ stehen.

Die Werte in B4:B15 spielen keine Rolle.

Wenn das gegeben ist, sollen die zutreffenden Zellen nicht mehr farblich formatiert, sondern weiß wie in der Ausgangssituation sein.

BedingtFaelle6

Dieser Link führt dich zur Beispieldatei:

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert

WordPress Cookie Plugin von Real Cookie Banner