Bedingte Formatierung von Werten über oder unter dem Durchschnitt

Die bedingte Formatierung der oberen oder unteren fünf oder zehn Werte u.a. war Gegenstand eines früheren Beitrags.

In diesem Beitrag soll es darum gehen, die Werte einer Datenreihe hervorzuheben, die über oder unter dem Durchschnitt der Datenreihe liegen.

Das schließt ein, dass der Durchschnittswert nicht formatiert wird.

Der Begriff „Durchschnitt“ soll der Excel-Funktionbezeichnung „MITTELWERT“ entsprechen.

„Bedingte Formatierung von Werten über oder unter dem Durchschnitt“ weiterlesen

Bedingte Formatierung in Excel bei Datumswerten

Die bedingte Formatierung ist ein sehr nützliches Werkzeug in Excel.

Dadurch ist es möglich, bestimmte Sachverhalte in Listen und Tabellen hervorzuheben.

Im Blog gab es dazu bereits mehrfach Beiträge. Bei Bedarf kannst Du sie in der Kategorie „Format“ finden.

Der heutige Beitrag beschäftigt sich mit der bedingten Formatierung bei Datumswerten.

f0afe42292ab47dfafdbd37c82ac2492

„Bedingte Formatierung in Excel bei Datumswerten“ weiterlesen

Bedingte Formatierung mit der VERGLEICH-Funktion

Angenommen, Du hast eine Städteliste, hier im Beispiel sind 33 Städte aus Mecklenburg-Vorpommern dargestellt. Im Land gibt es 84 Städte.

eefb39fa140b43f9ae666a2e0cba6239

bedformatstadt1

Vergib über Formel / Namen definieren für den Bereich A3:A35 den Namen „Städte“.

Weiterhin hast Du eine kleine Liste mit Filialen eines Handelsunternehmens.

bedformatstadt2

Vergib über Formeln / Namen definieren für den Bereich C3:C10 z.B. den Namen „Filialen“.

Die Aufgabe besteht nun darin, mittels bedingter Formatierung zu prüfen, ob die Städteliste die Orte der Filialen enthält.

Hierzu kannst Du die Funktion VERGLEICH nutzen.

VERGLEICH liefert eine Zahl, wenn eine Stadt auch in der Liste „Filialen“ vorhanden ist.

Beispiel:

Schreibe folgende Formel:

=VERGLEICH(A12;Filialen;0)

In A12 steht die Stadt  „Goldberg“. Diese Stadt ist in der Liste „Filialen“ enthalten.

VERGLEICH gibt deshalb den Wert „2“ zurück, die Position der Stadt in der Städteliste.

Schreibe noch eine Formel:

=VERGLEICH(A13;Filialen;0)

In A13 steht die Stadt „Grabow“. Diese Stadt wird nicht unter den Filialen gefunden. Excel gibt deshalb den Fehlerwert „#NV“ zurück.

Verwende nun die Formel in der bedingten Formatierung.

Markiere A3:A35. Gehe im Menü Start auf „Bedingte Formatierung“ und wähle „Neue Regel“.

Wähle dort „Formel zur Ermittlung der zu formatierenden Zellen verwenden“.

Schreibe in die Regelbeschreibung nun die Formel:

=VERGLEICH(A3;Filialen;0)

Gehe auf Formatieren und treffe Deine Auswahl. Hier im Beispiel wurde eine gelbe Hintergrundfarbe ausgesucht.

bedformatstadt3

Gebe „OK“. Die Städteliste ist nun bedingt formatiert.

bedformatstadt4

Nun könntest Du noch sicherstellen, dass das VERGLEICH-Ergebnis tatsächlich eine Zahl ist.

Schalte dazu einfach die Funktion ISTZAHL vor die VERGLEICH-Funktion.

bedformatstadt5

Auf die Städteliste hat dies jedoch keine sichtbaren Auswirkungen. Allein für die bedingte Formatierung genügt die Formel

=VERGLEICH(A3;Filialen;0)

Willst Du jedoch außerhalb der bedingten Formatierung weitere Aktionen vornehmen, kann das Vorsetzen von ISTZAHL sinnvoll sein.

Mit der Datenüberprüfung prüfen, ob Zellen Text enthalten

Die nachstehende Wertetabelle enthält zwölf Werte, die scheinbar alle Zahlen sind. Alle Werte sind außerdem rechts ausgerichtet.

Du möchtest prüfen, ob dem so ist. Dafür bieten sich mehre Möglichkeiten an.

Eine ist, in einer Spalte neben den Werten, z.B. in den Zellen D2:D13 die Formel

=ISTZAHL(B2)

zu schreiben und die Eingabe mit Strg + Enter abzuschließen. Wenn die Werte in B2:B13 Zahlen sind, wird in D2:D13 „WAHR“ ausgegeben.

Ist der Wert keine Zahl, wird „FALSCH“ ausgegeben. Dies ist im Beispiel der Fall für die Werte in B6 und B11.

Eine zweite Möglichkeit ist, in D2:D13 die Formel

=ISTTEXT(B2)

zu schreiben und mit Strg + Enter abzuschließen.

Die Zahlenwerte werden nun als „FALSCH“ gekennzeichnet. Nur in D6 und D11 steht „WAHR“, denn in B6 und B11 ist Text eingetragen.

Als dritte Möglichkeit bietet sich die bedingte Formatierung an.

Markiere B2:B13, gehe im Menü Start auf Formatvorlagen / Bedingte Formatierung. Wähle „Neue Regel“ und „Formel zur Ermittlung der zu formatierenden Zellen verwenden“.

Trage als Formel

=ISTTEXT(B2)

ein und wähle unter Formatieren „Ausfüllen“. Wähle eine Farbe aus.

Nach dem OK werden in der Tabelle die Textwerte in der gewünschten Farbe markiert.

Die bedingte Formatierung kannst Du natürlich auch mit der Funktion ISTZAHL() vornehmen.

Markiere auch jetzt B2:B13, gehe im Menü Start auf Formatvorlagen / Bedingte Formatierung. Wähle „Neue Regel“ und „Formel zur Ermittlung der zu formatierenden Zellen verwenden“.

Trage als Formel

=ISTZAHL(B2)

ein und wähle unter Formatieren „Ausfüllen“. Wähle eine Farbe aus.

Nach dem OK werden alle Zellen mit Zahlenwerten farblich markiert, die mit Textwerten bleiben weiß.

WordPress Cookie Plugin von Real Cookie Banner